#219 ✓resolved
Joey B

[patch attached] merb_datamapper rather than dm-merb

Reported by Joey B | April 20th, 2008 @ 11:53 AM

May we please go back to merb_datamapper as the name of our merb plugin? I know the rest of dm-more has dm-* naming, but there are two better reasons to use merb_datamapper:

1) It sticks with tradition so that "use_orm :datamapper" will work in merb's init.rb. This helps people move from dm 0.3 to 0.9 and beyond without confusion.

2) This chunk of code is an ORM plugin for merb. Merb's conventions should be followed. I don't think it should be a "merb vs. dm" naming thing ... it's pretty clear to me that this code exists to plug dm into merb (not the other way around).

I love both dm and merb, can we just get along? A patch is attached that makes the clean and consistent change to the dm-more git repo.

After applying this patch you can do a standard install of all the relevant packages and use "use_orm :datamapper" in your merb init.rb and have stuff just work.

Comments and changes to this ticket

  • Michael Klishin (antares)

    Michael Klishin (antares) April 20th, 2008 @ 09:20 PM

    I agree on this.

    Other thing I am concerned about is now in Merb app you can use_orm :dm_core and :datamapper, but they work with different versions.

    As DM moves forward with 0.9.x versions, does it make sense for Merb 0.9.x to support DM 0.3?

    I think enough people use Datamapper 0.9 already, and DM and Merb communities seem to be fine with living on the edge.

    Any thoughts?

  • Dan Kubb (dkubb)

    Dan Kubb (dkubb) April 20th, 2008 @ 09:45 PM

    • Milestone cleared.
    • State changed from “new” to “open”

    I agree that the current name should be changed. The only issue is that the project has been split into dm-core and dm-more, so it'll be

    a little weird for the plugin to use the word "datamapper" in its name.

    In #datamapper wycats suggested that the plugin be named merb_dm_core, which means that "use_orm :dm_core" would work in both old and new merb. I think this is the best approach suggested so far.

  • Joey B

    Joey B April 21st, 2008 @ 12:54 PM

    I'm not following your last statement there about a solution that suits both old and new. If we tell all newcomers to "use_orm :dm_core" ... then with the 0.3 dm code base, that will not work because there is no merb_dm_core.rb to load the plugin gem. Kernel.rb in merb-core would try to load merb_dm_core ... whereas it would really need to load merb_datamapper. Or am I missing something?

    However, I'm currently a proponent of making things work for 1.0 as best we can and only following backwards compatibility when it is convenient. There's a much larger road and developer base ahead than there is behind ... and the existing developer base could pick up the new customs easily enough.

    If people want to refer to datamapper as dm_core, that seems odd and wouldn't be my first choice, but it's 100% fine by me.

    Let's just make sure the decision is made and the code is brought together ASAP. If I see a seemingly definitive response here, I'll go ahead and create the same consistency for merb_dm_core that I did for merb_datamapper in the patch previously posted here.

    I'll be happy to have a set of glued out-of-the-box trunks again! :)

  • Sam Smoot

    Sam Smoot April 27th, 2008 @ 10:38 PM

    • State changed from “open” to “resolved”


Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »