#1458 ✓resolved
Nick

dm-is-remixable requires - but does not include - an inflector

Reported by Nick | December 17th, 2010 @ 06:14 AM | in 1.1

(Created on github initially, whoops)

https://github.com/datamapper/dm-is-remixable/issues/issue/8

If activesupport isn't present, dm-is-remixable fails with:

dm-is-remixable-1.0.2/lib/dm-is-remixable/is/remixable.rb:71:in `is_remixable': uninitialized constant ActiveSupport::Inflector (NameError)
    from dm-core-1.0.2/lib/dm-core/model/is.rb:23:in `is'
[...]

extlib (which is installed) seems to include an inflector, but dm-is-remixable doesn't bring it in like dm-core and dm-validations do?

require 'extlib/inflection'
module ActiveSupport
  Inflector = ::Extlib::Inflection
end

Before requiring dm-is-remixable seems to solve the problem for me, although I'm grappling with namespace issues at the moment (present with active_support's inflector too) so can't guarantee there aren't more problems

Comments and changes to this ticket

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Pages