#1331 ✓resolved

Cannot upgrade to DataMapper 1.0 via Gemfile

Reported by ravinggenius | June 18th, 2010 @ 01:22 PM

I have a Merb application that I haven't touched in about six months. The application was not ever finished and now I am upgrading it to Rails 3 beta 4. When I added DataMapper to the Gemfile (below) and ran bundle install, Bundler gives me the following error: "Could not find gem 'data_mapper~> 1.0 (>= 0, runtime)' in any of the gem sources." I tried changing source from :rubygems to 'http://rubygems.org', but still nothing. Also I verified that the data_mapper gem could be found on the RubyGems website. By the way I am using Bundler 0.9.26, if that helps.

How do I get DataMapper 1.0 to play nice with Bundler and Rails 3?

gem 'data_mapper'            '~> 1.0' # '~> 1.0.0' doesn't work either
gem 'dm-sqlite-adapter'      '~> 1.0'

Comments and changes to this ticket

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »