#1211 ✓not-applicable
Maxime Guilbot

dm-rails extlib inflections and activesupport inflector

Reported by Maxime Guilbot | March 5th, 2010 @ 09:39 AM

I caught ActionController#build_named_route_call using extlib's inflections instead of the activesupport inflections. Both defines String#singularize (and String#pluralize by the way).

This made my application generate wrong routes.. I don't know what's the best strategy to handle this problem. DM should use extlib's inflections and activecontroller activesupport ones..

Rails 3.0.0.beta1
dm-rails 0.10.2

Comments and changes to this ticket

  • Piotr Solnica (solnic)

    Piotr Solnica (solnic) March 5th, 2010 @ 10:03 AM

    • State changed from “new” to “unconfirmed”

    If you want to use DM with Rails3 you should grab dm-core and dm-more from snusnu's "active_support" branch:

    http://github.com/snusnu/dm-core/tree/active_support
    http://github.com/snusnu/dm-more/tree/active_support

  • Maxime Guilbot

    Maxime Guilbot March 6th, 2010 @ 06:34 AM

    Thanks for your feedback!

    Here's my Gemfile: http://gist.github.com/323664

    Coming from the dm-rails template, it does specify the active_support branch for dm-core and dm-more. Still, extlib gets loaded. During "bundle install", I get 'Installing extlib (0.9.14) from system gems'.

    Any clue?

  • Martin Gamsjaeger (snusnu)

    Martin Gamsjaeger (snusnu) March 8th, 2010 @ 11:22 AM

    • State changed from “unconfirmed” to “not-applicable”
    • Assigned user set to “Martin Gamsjaeger (snusnu)”

    Maxime,

    I believe your version constraints are too tight, and since your Gemfile "only" adds a git source for my forks and doesn't pin the gem to the git repo - for that you'd have to either add the git path as a :git option to the gem declaration or wrap everything inside a git '...' { ... } block - it just uses the proper 0.10.2 versions from rubygems (or system gems if you had them installed). Make sure that you specifiy your dm-* deps as '~> 0.10.2'. I just generated an app following the instructions in the dm-rails README and it didn't pull in extlib. I'm marking this as invalid, feel free to correct me if I'm wrong.

  • Maxime Guilbot

    Maxime Guilbot March 8th, 2010 @ 08:59 PM

    Martin,

    You are right, replacing '0.10.2' by '~> 0.10.2' is just enough to make the bundler use the code from your git repos instead of the system gems; and extlib doesn't get loaded, success!

    Ticket is invalid yes, thanks for your help!

    By the way, I couldn't find any documentation for the meaning of "~>" in gem bundler, any resource?

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Pages